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1 Mousing

First, how do we move around and select things?

Left-mouse Drag Rotate view
Ctrl Left-Mouse Drag Translates view
Shift Left-Mouse Label Atom
Right-Mouse Drag Zoom in and out
Middle-mouse Centre on atom
Scroll-wheel Forward Increase map contour level
Scroll-wheel Backward Decrease map contour level

2 Getting Started

In this tutorial, we will learn how to do the following:

1. Start Coot

2. Display coordinates

3. Display a map

4. Zoom in and out

5. Recentre on Different Atoms

6. Change the Clipping (Slab)

7. Recontour the Map

8. Change the Map Colour

9. Display rotamers and refine residue

2.1 Load tutorial data

To use coot, in a terminal window, type:
$ coot
When you first start coot, it should look something like Figure 1.
So let’s read in the coordinates and data (and thus generate a map)
To load the files on which we will be working:
From Coot’s main menu bar, select Extensions → Load tutorial model and

data
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Figure 1: Coot at Startup
Not much to see at present... Actually, after this, coot screenshots will be
displayed with a white background, whereas you will see a black one

Figure 2: Coot After Loading Coordinates
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2.2 Adjust Virtual Trackball

By default, Coot has a “virtual trackball” to relate the motion of the molecule
to the motion of the mouse. Many people don’t like this.

So you might like to try the following. In the Coot main menu-bar:
Edit → Preferences. . .
[Coot displays a Preferences window]
On the left toolbar select General and then on the right top notebook tab

HID. Select “Flat” to change the mouse motion.
(Use the “Spherical Surface” option to turn it back to how it is by default).
What is the difference? “Flat” mode is like the mode used by “O”. In both

modes, dragging the mouse near the centre of the screen causes the view to
rotate about the X- or Y- axis. However in spherical mode you can also rotate
about the z-axis by dragging the mouse along an edge of the window.

2.3 Display maps

We are at the stagewherewe are looking at the results of the refinement. The re-
finement programs stores its data (labelled lists of structure factor amplitudes
and phases) in an “MTZ” file. Let’s take a look. . .

• Select “File” from the Coot menu-bar

• Select “Auto Open MTZ” menu item [Coot displays a Dataset File Selec-
tion window]

• Select the filename rnasa-1.8-all refmac1.mtz

If you choose instead “Open MTZ, cif or phs...” you will see:

• [Coot displays a Dataset File Selection window]

• Select the filename rnasa-1.8-all refmac1.mtz

[Coot displays a Dataset Column Label Selection window]

Notice that you have a selection of different column labels for the “Am-
plitudes” and “Phases”, however, let’s use the defaults: “FWT” and “PHWT”.

• Press “OK” in the Column Label Window

Nowopen theMTZfile and select column labels “DELFWT” and “PHDELWT”.

So now we have 2 maps (whether auto-opened or not).

2.4 Zoom in and out

To zoom in, click Right-mouse and drag it left-to-right1. To zoom out again,
move the mouse the opposite way.

1or up-to-down, if you prefer that
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Figure 3: Coot MTZ Column Label Selection Window

Figure 4: Coot after reading an MTZ file and zoomed in.
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2.5 Recentre on Different Atoms

• Select “Draw” from the Coot menu-bar

• Select “Go To Atom. . . ”

[Coot displays the Go To Atom window]

• Expand the tree for the “A” chain

• Select 1 ASP in the residue list

• Click “Apply” in the Go To Atom window

• At your leisure, use “Next Residue” and “Previous Residue” (or “Space”
and “Shift” “Space”in the graphics window) to move along the chain.

• Click Middle-mouse over an atom in the graphics window

[Coot recentres on that atom]

• Ctrl Left-mouse & Drag moves the view around. If this is a too slow and
jerky:

– Select Edit → Preferences. . . from Coot’s menu-bar

– Select the “Maps” toolbutton on the left

– Select the “Dragged Map” notebook tab.

– Select “No” in the “Active Map on Dragging” window

– Click “OK” in the “Preferences” window

Now the map is recontoured at the end of the drag, not at each step2.

Another, additional way to make the movements faster is to change the
number of steps for the “Smooth Recentering”. Again you find this in the
“Preferences” (Preferences → General → Smooth Recentering). Change
the “Number of Steps” (the default is 40) to something smaller, e.g. 20.

• You can display the contacts too, as you do this:

– Select “Measures” from the Coot menu-bar

– Select “Environment Distances. . . ”

– Click on the “Show Residue Environment?” check-button

∗ Also Click “Label Atom?” if youwish the Cα atoms of the residues
to be labelled.

– Click “OK” in the Environment Distances window

– Click “Apply” in the Go To Atom window

[You can’t change the colour of the Environment distances]

You can turn off the Environment distances if you like.

2which looks less good on faster computers.
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Figure 5: Coot’s Go To Atom Window (it doesn’t look exactly like this any
more).
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Figure 6: Coot showing Atom Label and environment distances.

2.6 Change the Clipping (Slab)

• Select “Draw” from the Coot menu-bar

• Select “Clipping. . . ” from the sub-menu

[Coot displays a Clipping window]

• Adjust the slider to the clipping of your choice

• Click “OK” in the Clipping window

Alternatively, you can use “D” and “F”3 on the keyboard, or Control Right-
mouse up/down (Control Right-mouse left/right does z-translation).

2.7 Recontour the Map

• Scroll your scroll-wheel forwards one click4

[Coot recontours the map using a 0.05electron/Å3 higher contour level]

• Scroll your scroll-wheel forwards and backwards more notches and see
the contour level changing.

3think: Depth of Field.
4don’t click it down.
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• If you don’t have a wheel on your mouse you can use “+” and “-” on the
keyboard.

• Note that the “Scroll” button in the Display Manager allows you to select
which map is affected by this5.

2.8 Change the Map Colour

• Select “Edit” from the Coot menu-bar

• Select “Map Colour” in the sub-menu

• Select “1 xxx FWT PHWT” in the sub-menu

[Coot displays a Map Colour Selection window]

• Choose a new colour by clicking on the colour widgets

[Coot changes the map colour to match the selection ]

• Click “OK” in the Map Colour Selection window

2.9 Select a Map

Select a map for model building. We prefer you to use the modelling toolbar
icon buttons (here “Map”) displayed on the right side of the Coot window.
Note: If you are not sure which icon corresponds to which function look at the
displayed tips when over the button with the mouse. Or change the display
style of the buttons by clicking on the bottom arrow and select another style to
get only or additionally text displayed.

Right Toolbar: “Map” from the Modelling Toolbar

click OK (you want to select the map with “. . . FWT PHWT”)

Alternatively you can use the Model/Fit/Refine window:

Menubar: Calculate → Model/Fit/Refine...
[Coot displays the Model/Fit/Refine window]

Select “Select Map. . . ” from the Model/Fit/Refine window

click OK (you want to select the map with “. . . FWT PHWT”)

Note: Most options found in the Model/Fit/Refine window are available
in the Modelling Toolbar too. You can change this with Preferences.

5by default it is the last map, which is not necessarily the map that you want.
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3 Model Building

“So what’s wrong with this structure?” you might ask.
There are several ways to analyse structural problems and some of them

are available in Coot.

Validate → Density Fit Analysis → tutorial-modern.pdb
[Coot displays a bar graph]

Look at the graph. The bigger and redder the bar the worse the geometry.
There are 2 area of outstanding badness in the A chain, around 41A and 89A.

Let’s look at 89A first - click on the block for 89A.

[Coot moves the view so that 89A CA is at the centre of the screen ]

3.1 Rotamers

• Examine the situation. . . [ The sidechain is pointing the wrong way. Let’s Fix
it...]

• Modelling Toolbar: Select the “Rotamers” button

• Alternatively:

Menubar: Calculate → Model/Fit/Refine...

[Coot displays the Model/Fit/Refine window]

Select “Rotamers” from the Model/Fit/Refine window.

• In the graphics window, (left-mouse) click on an atom of residue 89A (the
Cγ, say)

[Coot displays the “Select Rotamer” window]

• Choose the Rotamer that most closely puts the atoms into the side-chain
density

• Click “Accept” in the “Select Rotamer” window

[Coot updates the coordinates to the selected rotamer]

• Click “Real Space Refine Zone” in the Model/Fit/Refine window6.

• In the graphics window, click on an atom of residue 89A. Click it again.

[Coot displays the refined coordinates in white in the graphics and a new
“Accept Refinement” window]

• Click “Accept” in the “Accept Refinement” window.

[Coot updates the coordinates to the refined coordinates. 89A now fits
the density nicely.]

6. . . or use the modelling toolbar button
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OK. That’s good.
Now, how about if we just use Real Space Refinement only?

• Click “Undo” twice

[Coot puts the sidechain back to the original position]

• Click “Real Space Refine Zone” in the Modelling Toolbar 7.

• In the graphics window, click on an atom of residue 89A. Click it again.

[Coot displays the refined coordinates in white in the graphics and a new
“Accept Refinement” window]

• Now using left-mouse, click and drag on the intermediate (white) CZ
atom of the PHE (if you mis-click the atom, the view will rotate).

• Can you pull the atom around so that the side-chain fits the density?

[Yes, you can]

Figure 7: 89A now fits the density nicely.

3.2 More Real Space Refinement

Now let’s have a look at the other region of outstanding badness:

7. . . or in the Model/Fit/Refine window
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• Click on the graph block for 41 A

[Coot moves the view so that 41A CA is at the centre of the screen]

• Examine the situation. . .

• Residue 41 is in a mess and not fitting to the density. Can you fix it?

[Yes, you can]

• The trick is Real Space Refine that zone. So. . .

• You can either Real Space Refine a few residues (40, 41 and 42) or just 41.
Take your pick.

• Click on “Real Space Refine Zone” in theModelling Toolbar (Model/Fit/Refine
window)

• Select a range by clicking on atoms in the graphics window (either atoms
in 40 then 42 or an atom in 41 twice)

[Coot displays intermediate (white) atoms]

• Click and drag on some atoms until the atoms fit nicely in the density.

If you want to move a single atom then Ctrl Left-mouse to pick and move
(just) that intermediate atom.

[Note: Selecting and moving just the Carbonyl Oxygen is a good idea - use Ctrl
Left-mouse to move just one atom.]

4 Extra Fun (if you have time)

4.1 Waters

Fit waters to the structure

• “Find Waters. . . ” in the Other Modelling Tools dialog 8, then OK (using
the defaults)

[Waters appear]

To check the waters:

• Click on “Measures” in the main menubar.

• Click on Environment Distances

• Click on the “Show Residue Environment?” check-button

• Change the distances as you like

8In older versions of Coot, the FindWaters button can be found in the Model/Fit/Refine dialog
or the water drop in the modelling toolbar
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• Use the Go To Atomwidget to go to the first water (probably towards the
end of the list of residues in Chain “W”)

• Use the Spacebar to navigate to the next residue (and Shift Spacebar to
go backwards)

• If you don’t like the fast sliding9 you can turn it off (if you haven’t done
so already):

– Click Edit → Preferences. . . in the main menubar

– Click General → “Smooth Recentering...”

– Click “No”

4.2 Working with NCS

The tutorial data has two-fold NCS. With good data it is interesting to investi-
gate the differences between the NCS copies. This may be done by comparing
the NCS related electron density, comparing the NCS related chains, or com-
paring the Ramachandran plots for related chains:

• Comparing the NCS related electron density.

Go to Calculate/NCS maps and select the first map and model. Now,
if you go to anywhere in the A chain, you will see two sets of electron
density - the original density for the A chain, and the density for the B
chain transformed to overlap the A chain density. This gives you a visual
comparison of any differences.

Look at the density in the B molecule. Why does the density not agree
here? (Hint: the NCS is not a 2-fold rotation in this case, it is improper).

• Comparing the NCS-related chains.

Go to Draw/NCS ghost control and select Display non-crystallographic
ghosts. You will now see a copy of the B chain superimposed on the
A chain. The B chain is draw using thin bonds.

Look for regions where the models differ. Using the NCS maps tool,
check that the differences in the models are supported by the density.

• Compare the NCS-related chains using “NCS jumping”.

This is an alternative way of examining NCS similarities and differences.
Use the Display Manager to undisplay the NCS maps you recently cre-
ated above.

Use the “Goto Atom” dialog and press the “Update from Current Posi-
tion” button.

[Coot shifts the centre of the screen to the closest displayed CA atom]

9it’s not very good for water checking
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Identify the chain that you are looking at (for example, by double-clicking
on an atom)

Now press the “o” key on the keyboard.

[Coot shifts the centre of the screen to a NCS-related chain]

Identify the chain that you are looking at now.

Press “o” again.

What is happening?

(Note: ”o” stands for “Other NCS-related chain”.)

• Comparing the Ramachandran plots for related chains.

Go to Validate/Kleywegt plot. Check the Use specific chain options and
select chains A and B. You will get a Ramachandran plot with equivalent
residues from the A and B chains linked by arrows. Long arrows indicate
significant differences. Click on a dot to view the residue concerned.

Another tool for identifying NCS differences is the Validate/NCS differ-
ences graph. This gives a clickable histogram of differences.

4.3 Add Terminal Residue

[To be found on the Modelling Toolbar10]

• Use the Go To Atom window to go to residue 72 A.

• What do you see?

[You see missing atoms (that is, you don’t see them). This residue is supposed to
be a CYS! Bad things have happened to it. Let’s get rid of this residue. ]

[There may also be waters in the side-chain positions too (they have to be removed
too).]

• Delete. . .

• (Make sure “Residue/Monomer” is active)

• Click on an atom of residue 72 A.

[Residue 72 A disappears]

• Lets’ put back an ALA.

• Add Terminal Residue. . .

[Coot adds intermediate white atoms and pops up a dialog]

• Accept the new atoms

OK, we now have a ALA. We want a CYS:

10and in the Model/Fit/Refine window
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• Mutate & Auto Fit. . .

• Click on an atom in the new ALA

[Coot pops up a residue type chooser]

• Choose residue type CYS

[Coot mutates and fits a CYS]

• Examine the situation.

[ There is an extra blob of density on that CYS. What is it?] It is an alternative
conformation.

Let’s model it

• Add Alt Conf. . .

[Coot pops up a residue splitter dialog]

• Choose how you want to split your residue (the Right Way is an unre-
solved philosophical issue. . . 11)

• Click on an atom in 72 A

[Coot adds intermediate white atoms and pops up a Rotamer Chooser]

• Choose the correct rotamer - it shouldn’t be difficult to tell which is the
closest.

• Accept when you are happy with you choice.

• Now optimize the fit of this new residue with Real Space Refinement.

The refinement of each alternate conformations is independent.

• Real Space Refine Zone

• click on (say) SG,B of 72A

• Press “A” (on the keyboard)

[Coot moves the atoms a bit]

• Accept

• Now do the same with the other conformation.

[Ahhh! Much better.]

11Actually Jane Richardson may disagree with that statement.
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4.4 Display Symmetry Atoms

To be found on “Draw” → “Cell & Symmetry” menu item in the main menu.
Try:

• Show Symmetry Atoms? → Yes

• Symmetry as Calphas? [on]

• Colour symmetry by molecule [on]

• Symmetry Radius 30Å

• Colour Merge → 0.1

• Show Unit Cell? [on]

• OK

• Zoom out and have a look at how the molecules pack together.

4.5 Skeletonization and Baton Building

You can calculate the map skeleton in Coot directly:
Calculate → Map Skeleton... → On.
This can be used to “baton build” a map. You can turn off the coordinates

and try it if you like (the Baton Building window can be found by clicking “Ca
Baton Mode. . . ” in the Other Modelling Tools dialog12).

If you want to do this, I suggest you use Go To Atom and start residue 2 A
(this allows you to build the complete A chain in the correct direction (it takes
about 15 minutes or so) and you can compare it to the real structure afterwards.

Remember, when you start, you are placing a CA at the baton tip and at
the start you are placing atom CA 1. This might seem that you are “double-
backing” on yourself - which can be confusing the first time.

4.6 Refine with Refmac

Refmac is a program that does Maximum Likelihood refinement of the model,
and the interface to it can be found on the Model/Fit/Refine dialog. (By de-
fault there is no icon on the toolbar for this action - open the window from
the calculate menu13). Now click on “Run Refmac. . . ” (at the bottom of the
Model/Fit/Refine window).

12this is quite advanced
13or add your own “Run Refmac” button to the toolbar or the main/top toolbar. To add the

button to the modelling/side toolbar, open the “Preference” window. Now go to Preferences →

General → Refinement Toolbar. In the right hand window scroll down and tick the box besides
“Run Refmac. . . ”. A corresponding button will appear on the modelling toolbar. Alternatively
you can add your own “Run Refmac. . . ” button to the top toolbar of the Coot window (only in
Python versions). Click Right-mouse on the toolbar (besides the “Display Manager” button) and
you will see a pop-up menu. Select “Manage Buttons”, tick the box besides “Add Alt Conf” and
click “Apply”. A new button named “Add Alt Conf” will appear on the toolbar.
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The defaults should be fine...
“Run Refmac” in the new window. . .
. . .Wait. . .
[The cycle continues. . . ]

• Use “Validate → Difference Map Peaks” to find interesting features in the
newly created map and model.

• Python enabled version only: a dialog with geometric outliers and other
interesting things (if they exist) detected by Refmac shows up 14.

5 Use the EDS and PDB REDO

• Let’s validate a structure deposited in the PDB.

• Use a web browser and go to http://eds.bmc.uu.se/eds/. Use the
keyword search to find the structure of a particular protein/ligand/author.

• File → Fetch PDB & Map Using EDS. . .

• Get the accession code and paste it into the entry box that pops up.

• Similarly, we can retrieve files from the PDB REDO server - this actually
refines the deposited structure against the deposited data, which often
results in a better map and model.

• Use the validation tools in Coot to examine how good a PDB file this is...

• [the Difference Map Peaks can be interesting]

Colophon

This document is written using XEmacs 21.5 in LATEX using AUCTEX and is
distributed with the Coot source code.

14This is an analysis from the Refmac log file and can alternatively be opened from Extensions...
→ Refine... → Read REFMAC log

17


